JDK8升级JDK11的一些注意事项

作者: jekkay 分类: java 发布时间: 2019-06-24 10:43

JDK8升级JDK11的一些注意事项

JDK8升级为JDK11的时候,大部分代码是不需要变更的,但是部分插件可能需要升级一下,下面是整理的部分注意事项:

Q1: 出现问题“ombok.javac.apt.LombokProcessor could not be initialized. Lombok will not run during this compilation: ”

直接把lombok依赖升级到最新版本,然后再将IDE中的lombok插件也升级一下即可。

官网: https://projectlombok.org/setup/maven

<dependency>
    <groupId>org.projectlombok</groupId>
    <artifactId>lombok</artifactId>
    <version>1.18.4</version>
    <scope>provided</scope>
</dependency>

Q2: 程序无法正常启动,提示TOMCAT版本不支持

将TOMCAT版本升级一下,目前我测试的版本9.0.21是没有任何问题的。

官网: https://tomcat.apache.org/download-90.cgi

如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!

发表评论

电子邮件地址不会被公开。

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据